Bug 2745 - [PDF viewer] Crash when click on button "Document Info"
Summary: [PDF viewer] Crash when click on button "Document Info"
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins (show other bugs)
Version: 3.8.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-10-04 14:16 CEST by Raphael Groner
Modified: 2012-10-05 21:31 CEST (History)
0 users

See Also:


Attachments
gdb backtrace (6.37 KB, text/plain)
2012-10-04 16:30 CEST, Raphael Groner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Groner 2012-10-04 14:16:13 CEST
Process receives signal 11.

Claws Mail version 3.8.1
GTK+ version 2.24.12 / GLib 2.32.4
Locale: de_DE.utf8 (charset: UTF-8)
Features: IPv6 iconv compface GnuTLS LDAP JPilot GNU/aspell libetpan libSM
Operating system: Linux 3.5.4-1-MANJARO (i686)
C Library: GNU libc 2.16
--
PDF viewer plugin 0.9.2
Comment 1 Salvatore De Paolis 2012-10-04 14:57:23 CEST
Hi,
any chance to provide some debug info? [1]

[1] http://www.claws-mail.org/faq/index.php/Debugging_Claws
Comment 2 Raphael Groner 2012-10-04 14:58:22 CEST
As it turned out, the crash is dependent on the very specific PDF. Unfortunately, I can't attach that file cause there are personal information in it that I don't want to share.
Maybe this document has no content at leads the plugin to crash?
Comment 3 Salvatore De Paolis 2012-10-04 15:07:38 CEST
Definitely, there's some kind of check missing on that side, so probably
an null value of a field in the documentation info might cause to free some memory that has never been allocated.
Some debug info would clear all doubts though.
Comment 4 Raphael Groner 2012-10-04 15:45:35 CEST
Output when claws-mail is called from a terminal in ArchLinux. I guess the last line comes when the button is clicked.

++ STATS ++ INC 0 0
claws.c:101:Starting Claws Mail version Claws Mail 3.8.1
main.c:858:runtime GTK+ 2.24.12 / GLib 2.32.4
main.c:866:buildtime GTK+ 2.24.10 / GLib 2.32.3
main.c:875:Compiled-in features:
main.c:880: compface
main.c:886: aspell
main.c:892: gnutls
main.c:898: ipv6
main.c:904: iconv
main.c:910: jpilot
main.c:916: ldap
main.c:922: libetpan 1.0
main.c:928: libsm
prefs_gtk.c:1037:new file '/home/raphael/.claws-mail/clawsrc'
prefs_gtk.c:996:new section 'Common'
prefs_gtk.c:996:new section 'Plugins_GTK2'
prefs_gtk.c:996:new section 'Plugins_Common'
prefs_gtk.c:996:new section 'fancy'
prefs_gtk.c:996:new section 'NotificationPlugin'
prefs_gtk.c:996:new section 'TrayIcon'
prefs_gtk.c:996:new section 'Bogofilter'
prefs_gtk.c:996:new section 'AttachWarner'
prefs_gtk.c:996:new section 'AddressKeeper'
prefs_gtk.c:996:new section 'AttRemover'
prefs_gtk.c:1037:new file '/home/raphael/.claws-mail/folderitemrc'
prefs_gtk.c:996:new section '#imap/web.de/Projects'
prefs_gtk.c:996:new section '#imap/web.de/Projekte'
prefs_gtk.c:996:new section '#imap/web.de/Rechtliches'
prefs_gtk.c:1037:new file '/home/raphael/.claws-mail/accountrc'
prefs_gtk.c:996:new section 'Account: 1'
prefs_gtk.c:996:new section 'Account: 2'
prefs_gtk.c:85:Reading configuration...
claws-mail: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Comment 5 Salvatore De Paolis 2012-10-04 15:48:50 CEST
can you type:

bt full after it hangs?
Comment 6 Raphael Groner 2012-10-04 16:30:09 CEST
Created attachment 1166 [details]
gdb backtrace
Comment 7 Salvatore De Paolis 2012-10-04 17:01:03 CEST
Hi, 
thanks for the backtrace, it doesn't seem to be a bug with the plugin or claws mail itself but more a GTK+ one.
I can't investigate further because I don't have a pdf to test, I'm sorry.
If you can, try to edit such pdf and delete the sensible data so that I can
see if I can reproduce the bug.
Comment 8 Raphael Groner 2012-10-04 18:33:33 CEST
Another system, it seems to be the same crash.

Claws Mail version 3.8.1
GTK+ version 2.24.13 / GLib 2.32.4
Locale: de_DE.utf8 (charset: UTF-8)
Features: IPv6 iconv compface GnuTLS LDAP JPilot GNU/aspell libetpan libSM
Operating system: Linux 3.0.43-1-lts (x86_64)
C Library: GNU libc 2.16
Comment 9 Salvatore De Paolis 2012-10-04 18:55:19 CEST
Is it possible for you to try with a version of GTK+ <= 2.24.10?
Comment 10 Raphael Groner 2012-10-05 18:24:51 CEST
I'll send you a file by e-mail (size ~1MB, 10 pages) that crashes on the system mentioned in comment #8.
Comment 11 Salvatore De Paolis 2012-10-05 21:31:15 CEST
Thank you, it helped to find out the issue.