Bug 2701 - vCalendar timezone and display
Summary: vCalendar timezone and display
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/vCalendar (show other bugs)
Version: 3.9.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-07-15 00:50 CEST by Pierre Fortin
Modified: 2014-04-22 15:58 CEST (History)
1 user (show)

See Also:


Attachments
initial vCalendar display (119.03 KB, image/png)
2012-07-15 00:51 CEST, Pierre Fortin
no flags Details
duplicate entries and wrong timezone (123.27 KB, image/png)
2012-07-15 00:52 CEST, Pierre Fortin
no flags Details
Wrong timezone (124.16 KB, image/png)
2012-07-15 00:55 CEST, Pierre Fortin
no flags Details
scrolled looks better except for timezone (148.82 KB, image/png)
2012-07-15 00:56 CEST, Pierre Fortin
no flags Details
valgrind output (3.72 KB, text/plain)
2012-11-20 11:35 CET, Pierre Fortin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Fortin 2012-07-15 00:50:05 CEST
3.8.1cvs14 vCalendar

When I open vCalendar, everything looks OK (screen shot 1).  Then I click to expand the display which begins a series of issues.

Issue 1: display start time remains at 08:00; but a number of hours are repeated at the bottom (screen shot 2). Note that timezone is OK for items with specific start/stop times; but timezone is not respected for full-day items.

Issue 2: if I open Preferences (over the calendar), or another window, or slide one over the calendar, the lower part of the display blanks.  This is probably what vCalendar should look like instead of the repeated entries in Issue 1 above.

Issue 3: scrolling calendar shows entire day (00-23) which looks better, except for timezone issue on full-day items.
Comment 1 Pierre Fortin 2012-07-15 00:51:14 CEST
Created attachment 1128 [details]
initial vCalendar display
Comment 2 Pierre Fortin 2012-07-15 00:52:04 CEST
Created attachment 1129 [details]
duplicate entries and wrong timezone
Comment 3 Pierre Fortin 2012-07-15 00:55:04 CEST
Created attachment 1130 [details]
Wrong timezone
Comment 4 Pierre Fortin 2012-07-15 00:56:20 CEST
Created attachment 1131 [details]
scrolled looks better except for timezone
Comment 5 Pierre Fortin 2012-11-20 11:35:00 CET
Created attachment 1189 [details]
valgrind output

"valgrind claws-mail", Config.... to blank Name list, closed windows & quit. Nothing else done.
Comment 6 Pierre Fortin 2012-11-20 11:36:19 CET
Argh...  valgrind output posted to wrong bug...  (up all night)
Comment 7 Pierre Fortin 2013-05-07 14:53:14 CEST
Duplicate of bug 1769?
Comment 8 Pierre Fortin 2014-04-22 15:58:19 CEST
This seems to be resolved.  Saw another bug's update (can't find it at the moment) that looked similar. Closing as resolved sometime before 3.9.3git81.