Bug 2694 - Claws freezes when creating new mail folder
Summary: Claws freezes when creating new mail folder
Status: RESOLVED DUPLICATE of bug 2933
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-07-10 04:03 CEST by Ed Rippy
Modified: 2013-06-30 13:11 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Rippy 2012-07-10 04:03:27 CEST
Setting up after fresh install of Ubuntu Precise 32-bit --
install Claws Mail from Ubuntu software ctr, run
select "Welcome to Claws mail" msg in Inbox
right-click msg, select "New..." from popup menu
[dialog box w/ entry widget "New Folder" appears]
-- try anything. Cannot change folder name, close dialog box, close Claws -- only can kill from cmd line after getting proc ID w/ ps.
Comment 1 Ed Rippy 2012-07-10 04:14:31 CEST
Claws 3.7.4 under Ubuntu Lucid (same machine) runs fine.
Comment 2 Paul 2012-07-15 05:54:01 CEST
I guess 3.8.0 works fine on ubuntu lucid also? It all works fine for me under ubuntu precise. It could be a GTK theme issue - there was a bug in the oxygen-gtk GTK+ theme, (which is now fixed), were you using this theme?
Is this still reproducible for you?
Comment 3 Ed Rippy 2012-07-18 04:28:42 CEST
-- Yes, installed 3.8.0 on Lucid, able to create new folder fine -- still same problem in Precise (theme: ambience or radiance). Can size, move, minimize, & maximize all Claws windows (window mgr ok) but Claws doesn't respond to any input -- keystrokes, button clicks, "close" box click
Comment 4 Ed Rippy 2012-07-18 04:33:14 CEST
***CORRECTION*** to original post: procedure:
select "Welcome to Claws mail" msg in Inbox
right-click msg, select "Move..." [not "new"]
click "New" button @ bottom of dialog box

-- Sorry for the confusion!
Comment 5 Ed Rippy 2012-07-18 05:34:53 CEST
More useful information: a backtrace (very long!)

Thread 3 (Thread 0xb5bffb40 (LWP 2875)):
#0  0xb7fdd422 in __kernel_vsyscall ()
#1  0xb745e380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb771ea7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb77110ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb771156b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb719a1ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb77346b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb7819d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb746cace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb6583b40 (LWP 2874)):
#0  0xb7fdd424 in __kernel_vsyscall ()
#1  0xb745e380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb771ea7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb77110ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb771156b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb658b134 in ?? ()
   from /usr/lib/i386-linux-gnu/gio/modules/libdconfsettings.so
#6  0xb77346b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb7819d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb746cace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb680c8c0 (LWP 2870)):
#0  0xb7fdd424 in __kernel_vsyscall ()
#1  0xb745e380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb771ea7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb77110ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb7711201 in g_main_context_iteration ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb7c50df1 in gtk_main_iteration ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#6  0x082a0f9d in input_dialog_open (title=0x82bb53e "New folder", 
    message=0x82bb520 "Input the name of new folder:", checkbtn_label=0x0, 
    default_string=0x82b423d "NewFolder", default_checkbtn_state=0, 
    remember=0x0) at inputdialog.c:450
#7  0x082a135c in input_dialog (title=0x82bb53e "New folder", 
    message=0x82bb520 "Input the name of new folder:", 
    default_string=0x82b423d "NewFolder") at inputdialog.c:108
#8  0x08107f33 in foldersel_new_folder (button=0x852be78, data=0x0)
    at foldersel.c:554
#9  0xb77d2243 in g_cclosure_marshal_VOID__VOIDv ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#10 0xb77d0727 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#11 0xb77e9a29 in g_signal_emit_valist ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#12 0xb77ea453 in g_signal_emit ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#13 0xb7b9421a in gtk_button_clicked ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#14 0xb7b95630 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#15 0xb77d21ec in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#16 0xb77cf2fd in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#17 0xb77d0484 in g_closure_invoke ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#18 0xb77e2535 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#19 0xb77ea2dc in g_signal_emit_valist ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#20 0xb77ea453 in g_signal_emit ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#21 0xb7b9413a in gtk_button_released ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#22 0xb7b94184 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#23 0xb7c538a2 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#24 0xb77cf2fd in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#25 0xb77d03d2 in g_closure_invoke ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#26 0xb77e270d in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#27 0xb77e9ff5 in g_signal_emit_valist ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#28 0xb77ea453 in g_signal_emit ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#29 0xb7d8d413 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#30 0xb7c51a6e in gtk_propagate_event ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#31 0xb7c51e00 in gtk_main_do_event ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#32 0xb7ac3758 in ?? () from /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
#33 0xb7710d86 in g_main_context_dispatch ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb7711125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb7711201 in g_main_context_iteration ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb7c50df1 in gtk_main_iteration ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#37 0x08108b4d in foldersel_folder_sel (cur_folder=0x8653dd0, 
    type=FOLDER_SEL_MOVE, default_folder=0x0, can_sel_mailbox=0)
    at foldersel.c:188
#38 0x0820689c in summary_move_to (summaryview=0x857ec20) at summaryview.c:4493
#39 0xb77d21ec in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#40 0xb77d0484 in g_closure_invoke ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#41 0xb77e20d9 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#42 0xb77ea2dc in g_signal_emit_valist ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#43 0xb77ea453 in g_signal_emit ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#44 0xb7b78da6 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#45 0xb7b797ed in gtk_action_activate ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#46 0xb77d21ec in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#47 0xb77cf2fd in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#48 0xb77d0484 in g_closure_invoke ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#49 0xb77e2535 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#50 0xb77ea2dc in g_signal_emit_valist ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#51 0xb77ea453 in g_signal_emit ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#52 0xb7d8c395 in gtk_widget_activate ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#53 0xb7c69667 in gtk_menu_shell_activate_item ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#54 0xb7c69a71 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#55 0xb7c5ccad in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#56 0xb7c538a2 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#57 0xb77cf2fd in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#58 0xb77d0484 in g_closure_invoke ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#59 0xb77e270d in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#60 0xb77e9ff5 in g_signal_emit_valist ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#61 0xb77ea453 in g_signal_emit ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#62 0xb7d8d413 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#63 0xb7c51a6e in gtk_propagate_event ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#64 0xb7c51e00 in gtk_main_do_event ()
   from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#65 0xb7ac3758 in ?? () from /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
#66 0xb7710d86 in g_main_context_dispatch ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
#67 0xb7711125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#68 0xb771156b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#69 0xb7c50b8f in gtk_main () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#70 0x0807feb7 in main (argc=1, argv=0xbffff3f4) at main.c:1653
Comment 6 Ed Rippy 2012-07-18 05:52:22 CEST
A couple of other notes: I can create a new folder by right-clicking on an existing folder and then move or copy the msg to the new folder (& back). Claws only hangs when I try to create a new folder from within a Move... or Copy... dialog box.
Comment 7 Ed Rippy 2012-07-30 01:41:31 CEST
Progress: Built 3.8.0 in Eclipse Juno & single-stepped. Claws is stuck in a loop in input_dialog_open() (src file inputfile.c):

[set up & show GtkDialog w/ a text entry & 'cancel' & 'ok' buttons]
...
ack = fin = FALSE;

while (fin == FALSE)
	gtk_main_iteration();

...

(callbacks connected to buttons etc. set (global) var's ack & fin.)

It seems that the window events are not triggering the callbacks, although they do when a new folder is created by right-clicking on 'Mailbox' (in the main folder window) & selecting 'Create new folder...' (events are also getting thru under Lucid).

Precise has libgtk 2.24.10-0ubuntu6; Lucid has libgtk 2.20.1-0ubuntu2.1
Comment 8 Paul 2012-07-30 08:18:40 CEST
Again, works for me
Comment 9 Daniele 2012-10-20 15:47:56 CEST
I have the same problem with version 3.8.1 (gtk+ 2.24.10) and Ubuntu 12.04.1. I have seen that there has been no activity related this bug for some time and that the bug is still open.
This is actually a known bug which accurs also in some filtering configuration dialog boxes and which is claimed to be solved in

http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2624

Unfortunately, I can confirm that the bug is still there. It is not obvious to me whether the bug is due to claws-mail or to some Ubuntu personalization of gtk+ libraries (I am not used to Ubuntu and on other system claws-mail works fine).
Comment 10 Paul 2012-10-21 12:20:04 CEST
All the same here:

version 3.8.1 (gtk+ 2.24.10) and Ubuntu 12.04.1.

But with no problem.

There must be something on your system which is different. Tell us more. GTK+ theme, desktop, anything else you may think is related
Comment 11 Daniele 2012-10-21 15:15:19 CEST
Unfortunately, there is nothing particular with configuration: this is not a box I am using regularly, so that there is no personalization from my side. I am using Ubuntu gnome with window theme "ambiance", icon theme "ubuntu-mono-dark", gtk+theme "ambiance".
I tried to ssh from another machine and open claws-mail via X forwarding and I have the same problem (claws-mail launched directly on the other machine works fine, but this is not Ubuntu).
I tried to define a new user and I have the same problem with a vanilla configuration.
Comment 12 Daniele 2012-10-28 12:53:02 CET
I made some more tests concerning this issue and I can confirm that the bug is still present. In particular:

1. The bug can be easily reproduced by booting Ubuntu 12.04.1 LTS from a USB memory stick. Just select "Try Ubuntu", configure the network, and install claws-mail. I tried with two different computers and the bug is there.

2. I reproduced the bug also on a new fresh installation. Just install Ubuntu 12.04.1 LTS, configure a default user, install all the updates, and install claws-mail. The bug is there.

Paul: it would be nice to know something more about your configuration. What is particular with your configuration that makes claws-mail work?
Comment 13 Paul 2013-01-21 18:34:58 CET
It's a problem of Unity on Ubuntu.
Comment 14 Paul 2013-06-30 13:11:04 CEST
This caused by ubuntu's overlay-scrollbar-gtk2, which breaks modal dialogues.

*** This bug has been marked as a duplicate of bug 2933 ***