Bug 2666 - Filtering rules disappearing randomly + can't add filtering/processing rule.
Summary: Filtering rules disappearing randomly + can't add filtering/processing rule.
Status: RESOLVED DUPLICATE of bug 2624
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Filtering (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-05-22 04:28 CEST by Drey Tee
Modified: 2012-05-23 09:44 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drey Tee 2012-05-22 04:28:53 CEST
I'm exepreincing problems, which freak me out (time wasting):
I wanna organise my mail by means of filtering/processing, created few folders and started to tune filtering my subject/to/from.
Created few filters successfully and wanted to create another one.
Opened filtering menu, filled condition field, clicked on  define button near "action"-field and got popup in which I can't type anything and can't even close the popup!
Soon I realized, that I still can type in backgrounded filtering window, though I cannot see blinking cursor. So I managed to clean all new edited fields and click cancel to close Filtering window, then I became able to type in and close a popup. But later when I reopened filtering window I see no filter rules!

It happened to me few times already. I tried to save config files previously (~/.claws-mail/*) and restore - but no luck. And I can't find file, containing filters neither.

I'm in frustration. Any help would be appreciated.

I ran claws-mail --debug from command-line.
Got debug in the right moment ( opening action popup from filtering window):
prefs_filtering.c:175:called inc_lock (lock count 1)
(claws-mail:6843): GLib-CRITICAL **: g_completion_add_items: assertion `cmp != NULL' failed
addr_compl.c:300:read 103 items in (null)
addr_compl.c:361:start_address_completion((null)) ref count -1
prefs_filtering_action.c:274:called inc_lock (lock count 2)
prefs_filtering_action.c:380:Creating matcher configuration window...
Comment 1 Paul 2012-05-22 07:14:07 CEST
The first part of your problem has been reported in bug #2624 and is now fixed.
Your filters won't get saved if you click the Cancel button.
The name (matcherrc) and location of the file that holds the filtering and processing rules can be found on the man page `man claws-mail` and the FAQ, http://www.claws-mail.org/faq/index.php/Installation_and_Configuration#What_configuration_files_are_there.2C_and_what_are_they_used_for.3F

*** This bug has been marked as a duplicate of bug 2624 ***
Comment 2 Drey Tee 2012-05-23 09:44:13 CEST
>> The first part of your problem has been reported in bug #2624 and is now fixed.
Thanks.
Downloaded src, applied a patch, but can't ./configure:
"configure: error: Package requirements (glib-2.0 >= 2.6 gmodule-2.0 >= 2.6 gobject-2.0 >= 2.6 gthread-2.0 >= 2.6) were not met:

No package 'glib-2.0' found
No package 'gmodule-2.0' found
No package 'gobject-2.0' found
No package 'gthread-2.0' found"

tried to build previous claws-mail-3.7.10, but got the same error.
I understand that it's not about this bug, but if you can help I would appreciate!



>> Your filters won't get saved if you click the Cancel button.
The file matcherrc becomes virgin new (40kb) in every case, even if I had tons of filters previously.

>> The name (matcherrc) and location of the file that holds the filtering and
>> processing rules can be found on the man page `man claws-mail` and the FAQ
Thanks,  now I see this file and file's .bak.
Pity, but my backup (which I done few weeks before doesn't contain this file (with tons of filters) I don't know why.