Bug 2600 - Claws Mail crashes showing GPG signature information
Summary: Claws Mail crashes showing GPG signature information
Status: RESOLVED DUPLICATE of bug 2689
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Privacy/PGP (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-02-11 20:14 CET by Kyrill Detinov
Modified: 2012-07-15 19:01 CEST (History)
0 users

See Also:


Attachments
crash log (4.65 KB, text/plain)
2012-02-11 20:14 CET, Kyrill Detinov
no flags Details
crash-log (15.35 KB, text/plain)
2012-07-05 09:45 CEST, Kyrill Detinov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyrill Detinov 2012-02-11 20:14:41 CET
Created attachment 1075 [details]
crash log

openSUSE 12.2 (not released yet, in Factory stage) x86_64.
Claws Mail 3.8.0.

When I click on gpg-signed icon to take info about the signature, the program crashes.

How to reproduce:
Open a GPG-signed message.
Click on icon that displays GPG sign.
Claws Mail crashes.

It happens in both cases: inline and attached GPG signature.

There were no crashes in version 3.7.10.

Crash log attached.
Comment 1 Kyrill Detinov 2012-07-05 09:45:46 CEST
Created attachment 1125 [details]
crash-log

I'm sorry to say, it doesn't work for me.
Comment 2 Ricardo Mones 2012-07-05 10:17:30 CEST
Probably same as http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2689
Comment 3 Kyrill Detinov 2012-07-05 11:31:35 CEST
Thanks, Ricardo. The patch helps.

Fixed in openSUSE: https://bugzilla.novell.com/show_bug.cgi?id=770014
Comment 4 Kyrill Detinov 2012-07-15 19:01:58 CEST
Fixed in #2689

*** This bug has been marked as a duplicate of bug 2689 ***