Bug 2599 - claws-mail freezes
Summary: claws-mail freezes
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.7.8
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-02-09 10:01 CET by pierrick.pons
Modified: 2012-02-09 12:43 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierrick.pons 2012-02-09 10:01:51 CET
Hi all,

I still have problems with Claws-mail.
It's really a pity that this wonderful and powerful mailer is so full of bugs or little problems.


Here is my debug output when Claws-mail is freezing :

folder.c:1208:Counting total number of messages...
main.c:971:The name com.google.code.Awn was not provided by any .service files
gtkhtml2_viewer.c:446:gtkhtml2_clear_viewer
    message/rfc822 (offset:0 length:13241 encoding: 6)
        text/html (offset:3653 length:9588 encoding: 3)
gtkhtml2_viewer.c:446:gtkhtml2_clear_viewer
gtkhtml2_viewer.c:446:gtkhtml2_clear_viewer
textview.c:655:TIMING textview_add_part : 0s001ms
textview.c:1058:Viewing text content of type: html (length: 9102)
textview.c:758:TIMING textview_add_part : 0s031ms
textview.c:775:TIMING recursive_add_parts : 0s031ms
textview.c:821:TIMING recursive_add_parts : 0s033ms
textview.c:583:TIMING textview_show_part : 0s033ms
mimeview.c:703:text/html
gtkhtml2_viewer.c:131:gtkhtml2_get_widget: 0xcb64640
summaryview.c:3302:flags: doing unset now
procmsg.c:1947:Unsetting flags for message 73092 in folder inbox
folder.c:1208:Counting total number of messages...
main.c:971:The name com.google.code.Awn was not provided by any .service files
summaryview.c:3505:TIMING summary_display_msg_full : 0s102ms
gtkhtml2_viewer.c:269:gtkhtml2_show_mimepart
gtkhtml2_viewer.c:301:using charset iso-8859-15 by default



I can't do anything, I have to kill -9 claws-mail ...

Do you have any idea of what it should be ?

Thanks in advance .
Comment 1 Paul 2012-02-09 11:20:36 CET
It looks like it could be in the Gtkhtml2 Viewer plugin. try unloading that plugin, see if it still happens. That is, if it something that is reproducible. You should also upgrade to the latest release (as it requests on the page where you entered this bug report). Also it may help to avoid exaggeration: 'so full of ...' etc.
Comment 2 pierrick.pons 2012-02-09 12:02:39 CET
Hello,

Thank you for your help.

I'm sorry for my bad comments, I adore Claws-mail but unfortunately Claws-mail bugs or freezes many times a day !
It's not serious to have a mailer that crashes so often.

Every answer you made is to unload a module. I'm sorry but I want to see outlook breifing and I do want to read html messages.
For you information, I can't use Claws-mail when Fancy module is loaded because Claws-mail crashes.

I use Claws-mail 3.7.8 version because it seems to be the stable version for my Ubuntu.
Comment 3 Paul 2012-02-09 12:09:35 CET
upgrade using our the official PPA: https://launchpad.net/~claws-mail/+archive/ppa
then report back. thanks.
Comment 4 pierrick.pons 2012-02-09 12:43:22 CET
Hello,

I've upgraded to Claws-mail v3.8.0 .

for information to Ubuntu users :
sudo add-apt-repository ppa:claws-mail/ppa


Thank you.