Bug 2581 - expander arrows are too tiny to hit with the mouse
Summary: expander arrows are too tiny to hit with the mouse
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 enhancement
Assignee: users
URL:
: 2716 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-19 14:05 CET by Tom Horsley
Modified: 2017-04-06 00:52 CEST (History)
1 user (show)

See Also:


Attachments
patch for making hotspot bigger (2.62 KB, patch)
2012-09-29 19:45 CEST, Tom Horsley
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Horsley 2012-01-19 14:05:15 CET
I'm not sure when this changed, but in the 3.8.0 claws-mail I have installed from the fedora 16 repos, the little tiny black arrows you need to hit to do things like expand or collapse a folder are so microscopically small, I usually miss them when trying to click on them.

There is a vast amount of space available for the tiny arrows to draw in. If you really like the tiny arrows, why not at least make the actual icons be bigger with transparent space around them so I could just click somewhere near them without having to hit the microscopic dot exactly on top of it.
Comment 1 Tom Horsley 2012-01-21 04:38:54 CET
Having valiantly ploughed through the claws source code, I'm guessing that what I really want is for the ctree_is_hot_spot routine to give me some slack. I don't really understand the code (and will bite my tongue to refrain from editorial comments on the gtk toolkit :-), but I do see that PM_SIZE is only 8, and a screenshot tells me that the row height is about 18. I can't actually imagine any reason to ignore a click anywhere in the column, what else could it mean other than expand or collapse? If that's the case maybe all that insanely complex routine should be doing is checking the event location against the clist->column[ctree->tree_column].area rectangle?
Comment 2 wwp 2012-08-30 12:29:16 CEST
*** Bug 2716 has been marked as a duplicate of this bug. ***
Comment 3 Tom Horsley 2012-09-29 19:45:09 CEST
Created attachment 1162 [details]
patch for making hotspot bigger

This finally made me crazy enough that I dug up the fedora source rpm and patched the sctree_is_hot_spot routine (which the debugger disclosed was the one that is used in the folder tree where I have the most problems). I don't actually understand what I really did, but it sure seemed that the PM_SIZE constant was used to determine the size when drawing the microscopic arrows, so in the hotspot check, I just made it 3 times bigger, and now I just need to click close to it, not directly on top of it. I hope this can be incorporated officially real soon now :-).

I found another *_is_hot_spot routine that might need the same treatment, but I was never able to determine when it actually gets used, so I didn't fool with it.
Comment 4 wwp 2012-10-01 14:07:36 CEST
The click-sensible area is more comfortable with you patch applied, right!
Comment 5 wwp 2012-10-01 14:18:18 CEST
Additionally, the other *_is_hot_spot function is bound to CMCTREE widget handling, which is used in Newsgroup's grouplistdialog.c, you can see where it displays when you add a newsgroup account, then in the News folder, right click and do "Subscribe to newsgroup..".
You're right, the same modifications should be done there too.
Comment 6 users 2012-10-12 14:48:34 CEST
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.claws-mail.org/tracker/

2012-10-12 [colin]	3.8.1cvs96

	* src/gtk/gtkcmctree.c
	* src/gtk/gtksctree.c
		Fix bug #2581, "expander arrows are too tiny to hit with the 
		mouse". Patch mostly by Tom Horsley
Comment 7 Ricardo Mones 2017-04-06 00:52:40 CEST
Fixed in 2012.