Bug 2559 - In openSUSE 12.1, Claws crashes when "fancy" plug-in is loaded.
Summary: In openSUSE 12.1, Claws crashes when "fancy" plug-in is loaded.
Status: RESOLVED DUPLICATE of bug 2507
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.7.10
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2011-12-06 20:04 CET by Graham P Davis
Modified: 2011-12-06 23:47 CET (History)
0 users

See Also:


Attachments
Crash log (3.55 KB, text/plain)
2011-12-06 20:05 CET, Graham P Davis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham P Davis 2011-12-06 20:04:36 CET
Claws without "fancy" starts OK but as soon as I try to load it, a crash occurs. The problem does not occur in openSUSE 11.4. I've also reported the problem to openSUSE: https://bugzilla.novell.com/show_bug.cgi?id=731022
Comment 1 Graham P Davis 2011-12-06 20:05:30 CET
Created attachment 1047 [details]
Crash log
Comment 2 Paul 2011-12-06 20:14:43 CET
what version of the plugin and what version of webkit is installed.
The crash log isn't much use because of the stripped binaries.
Comment 3 Graham P Davis 2011-12-06 22:58:05 CET
Plugins are in a package "claws-mail-extra-plugins," version 3.7.10-36.9
As to webkit, I'm not sure which module you need (of seven).
kwebkitpart: 1.2.0git20111019-1.2
libQTWebKit4: 4.7.4+2.2.0-2.1.2
libwebkitgtk-1_0-0; libwebkitgtk-3_0-0: 1.6.1-2.1.2

Running from command line gave the following error:
** (claws-mail:5891): WARNING **: plugin loading error: /usr/lib64/claws-mail/plugins/fancy.so: undefined symbol: webkit_web_view_get_selected_text

I'm now installing all debug packages and by the time that's finished - tomorrow - I'll try another run.
Comment 4 Ricardo Mones 2011-12-06 23:10:50 CET
Yet another duplicate of http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2507
Comment 5 Salvatore De Paolis 2011-12-06 23:47:13 CET

*** This bug has been marked as a duplicate of bug 2507 ***