Bug 2554 - Support libchamplain 0.10 and above in the geolocation plugin
Summary: Support libchamplain 0.10 and above in the geolocation plugin
Status: RESOLVED PATCHESWELCOME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/GeoLocation (show other bugs)
Version: 3.7.10
Hardware: PC Linux
: P3 enhancement
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2011-11-29 17:50 CET by Michael Schwendt
Modified: 2015-10-02 10:40 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Schwendt 2011-11-29 17:50:15 CET
Several methods no longer exist. Patching just the pkg-config file doesn't suffice this time. Implicit declarations lead to the plugin failing to load.
Comment 1 Holger Berndt 2011-11-29 21:47:46 CET
From 0.10 on, libchamplain needs GTK+ 3. As GTK+ 2 and 3 cannot be mixed in the same process, support for libchamplain >= 0.10 is only possible once Claws Mail works with GTK+ 3.
Comment 2 Michael Schwendt 2011-11-29 22:22:33 CET
Confirmed. I've made the same discovery meanwhile.
Thanks for the quick reply, Holger!