Bug 2549 - addressbook error
Summary: addressbook error
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Address Book (show other bugs)
Version: 3.7.8
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2011-11-23 17:59 CET by tneo
Modified: 2012-07-25 06:12 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tneo 2011-11-23 17:59:57 CET
The latest version 3.7.8-8.7 x64_68 provides an error message when starting up claws an error message is displayed. Hitting close does start Claws, though my addressbook is empty and doesn't contain all my addresses. 

Pop-up message
Addressbook error

Could not read address index
Comment 1 Paul 2011-11-23 19:43:20 CET
is ~/.claws-mail/addrbook/ writable?

That error is related to a missing addrbook--index.xml, which would normally get re-created automatically.

Anyway, this is not a bug, but related to your setup.
Comment 2 tneo 2011-11-24 08:13:09 CET
It is writable, date changes after starting claws. I noticed a bunch of old .bak files. Removed those and now I have an empty address book and no error, but not my addresses.
Comment 3 Christian Weiske 2012-07-25 06:12:55 CEST
I got the same message. Symptoms: Address book empty, and addrbook--index.xml is 0 bytes.

After removing the 0 byte file, it gets properly recreated and the message does not appear anymore.