Bug 2533 - undefined symbol: webkit_web_view_get_selected_text
Summary: undefined symbol: webkit_web_view_get_selected_text
Status: RESOLVED DUPLICATE of bug 2507
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.7.10
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2011-11-01 14:02 CET by Mihai Dontu
Modified: 2011-11-01 14:27 CET (History)
0 users

See Also:


Attachments
fancy fix for webkit 1.6.x (2.92 KB, patch)
2011-11-01 14:03 CET, Mihai Dontu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Dontu 2011-11-01 14:02:05 CET
With the latest version of webkit-gtk (1.6.1-r200 in my Gentoo repository) the plugin does not load because of the missing symbol 'webkit_web_view_get_selected_text'. Also the plugin cannot be built against GTK 3.x because GtkAdjustment is an opaque object now and so the 'value' property is not longer directly accessible. The attached patch fixes all these issues. Please see this[1] Gentoo bug for more information.

Thanks,

[1] https://bugs.gentoo.org/show_bug.cgi?id=385661
Comment 1 Mihai Dontu 2011-11-01 14:03:54 CET
Created attachment 1036 [details]
fancy fix for webkit 1.6.x

Mm. The patch was not picked up by the initial edit.
Comment 2 Salvatore De Paolis 2011-11-01 14:27:08 CET
Adding the GtkAdjustment bit in CVS, thanks

*** This bug has been marked as a duplicate of bug 2507 ***