Bug 2507 - fancy plugin doesn't load with latest webkit ; webkit_web_view_get_selected_text undefined
Summary: fancy plugin doesn't load with latest webkit ; webkit_web_view_get_selected_t...
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.7.10
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 2514 2527 2533 2539 2559 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-28 19:54 CEST by Julien
Modified: 2011-12-06 23:47 CET (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien 2011-09-28 19:54:15 CEST
Hi,

with last version of webkitgtk, webkit_web_view_get_selected_text has been removed ( https://bugs.webkit.org/show_bug.cgi?id=62512 ) and fancy plugin cannot be loaded anymore.

The following error occurred while loading fancy.so :

/usr/lib64/claws-mail/plugins/fancy.so: undefined symbol:
webkit_web_view_get_selected_text

thanks.
Comment 1 andyrtr 2011-09-29 08:50:39 CEST
http://git.xfce.org/apps/midori/commit/?id=648d869e4ff69f121da97484a0fd553b005ca751

I guess fancy needs a similar solution.
Comment 2 Salvatore De Paolis 2011-09-29 13:56:37 CEST
Well..to say it all, the bug should be first about webkit3 not being supported by the plugin and after about API changes.
How did you manage to compile the plugin with wekbkit3 without changing the sources?
Comment 3 Salvatore De Paolis 2011-09-29 15:15:27 CEST
Please could you tell me your version of webkitgtk?
It seems this change has been introduced in 1.5.1
Comment 4 Julien 2011-09-29 19:22:04 CEST
we are using webkit 1.6.1 (development version of mageia)
Comment 5 Salvatore De Paolis 2011-09-30 01:25:47 CEST
Thanks for reporting, has been fixed in 0.9.14cvs1
Comment 6 Salvatore De Paolis 2011-10-06 13:28:14 CEST
*** Bug 2514 has been marked as a duplicate of this bug. ***
Comment 7 Salvatore De Paolis 2011-10-27 00:29:17 CEST
*** Bug 2527 has been marked as a duplicate of this bug. ***
Comment 8 Salvatore De Paolis 2011-11-01 14:27:08 CET
*** Bug 2533 has been marked as a duplicate of this bug. ***
Comment 9 Keith 2011-11-08 12:33:47 CET
*** Bug 2539 has been marked as a duplicate of this bug. ***
Comment 10 Salvatore De Paolis 2011-12-06 23:47:13 CET
*** Bug 2559 has been marked as a duplicate of this bug. ***