Bug 2262 - Frequent occurrences of "Could not queue message for sending"
Summary: Frequent occurrences of "Could not queue message for sending"
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.7.6
Hardware: PC Windows XP
: P3 normal
Assignee: users
URL:
: 2289 2706 3674 3803 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-07 08:02 CEST by Dmitry Konyshev
Modified: 2017-04-08 22:58 CEST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Konyshev 2010-09-07 08:02:27 CEST
Sometimes (and very often for large emails) I get the "Could not queue message for sending" when clicking the Send button in the Compose window. Same happens when trying to save drafts.

After some debugging, the problem looks to originate from the libetpan library which doesn't handle the winsock2 "send" function's completion codes correctly. Specifically, "send" invoked from the end of mailstream_low_socket_write in libetpan/src/data-types/mailstream_socket.c sometimes returns -1 with WSAGetLastError() indicating error code WSAWOULDBLOCK. MSDN recommends some retries in this case:

=======
WSAEWOULDBLOCK
10035
Resource temporarily unavailable.
This error is returned from operations on nonblocking sockets that cannot be completed immediately, for example recv when no data is queued to be read from the socket. It is a nonfatal error, and the operation should be retried later. It is normal for WSAEWOULDBLOCK to be reported as the result from calling connect on a nonblocking SOCK_STREAM socket, since some time must elapse for the connection to be established.
=======
Comment 1 Colin Leroy 2012-11-15 10:54:48 CET
*** Bug 2289 has been marked as a duplicate of this bug. ***
Comment 2 Colin Leroy 2012-11-15 10:55:22 CET
*** Bug 2706 has been marked as a duplicate of this bug. ***
Comment 3 Colin Leroy 2012-11-15 10:56:07 CET
Does this still happen with new builds (which ship a newer libetpan) ?
Comment 4 Dmitry Konyshev 2013-07-26 20:00:41 CEST
The issue still exists in 3.9.0cvs98.
Comment 5 blob800 2014-05-06 01:46:56 CEST
I have this issue with 3.8.1. Especially with attachments.
Comment 6 Andres 2015-07-23 19:16:02 CEST
Ditto, except -only- when I include an attachment.
Comment 7 NeedMoreCoffee 2016-04-05 14:56:04 CEST
Same problem. The moment I add an attachment to the mail, I can't send it because of this error.

Version 3.13.2 on Windows 7 x64.
Comment 8 Andrej Kacian 2016-04-05 15:45:28 CEST
How does network log (look in Tools menu) from such a send attempt look like? Odds are there won't be anything useful, but for the sake of completeness, let's see it.

Also, have you reported this bug to libetpan developer?
Comment 9 Marc 2016-04-13 03:20:23 CEST
Did anyone get this resolved? I use Ubuntu and Windows and would like to move away from Thunderbird and Outlook but without the ability to send attachments Claws won't work. 


(In reply to comment #7)
> Same problem. The moment I add an attachment to the mail, I can't send it
> because of this error.
> 
> Version 3.13.2 on Windows 7 x64.
Comment 10 Paul 2016-04-13 09:33:25 CEST
(In reply to comment #9)
> Did anyone get this resolved? I use Ubuntu

It's a windows issue.
Comment 11 Andrej Kacian 2016-04-13 10:11:43 CEST
Also, it is an issue none of the developers are able to reproduce. Therefore it's not likely that a fix will be forthcoming. The source code is available, though, and I will gladly accept a patch - either for Claws Mail, or for libetpan - which fixes this issue for those who can reproduce it.
Comment 12 Paul 2016-08-20 18:37:53 CEST
*** Bug 3674 has been marked as a duplicate of this bug. ***
Comment 13 Andrej Kacian 2017-04-08 22:55:16 CEST
*** Bug 3803 has been marked as a duplicate of this bug. ***
Comment 14 Andrej Kacian 2017-04-08 22:58:41 CEST
Fixed in commits
http://git.claws-mail.org/?p=claws-win32-installer.git;a=commitdiff;h=a9eee6
http://git.claws-mail.org/?p=claws-win32-installer.git;a=commitdiff;h=859187

The patch is somewhat heavy-handed, but it should suffice.