Bug 2093 - Posting to SSL enabled news server appears to stall after DATA phase
Summary: Posting to SSL enabled news server appears to stall after DATA phase
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.7.4
Hardware: PC Windows XP
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2010-01-05 13:39 CET by Brian Morrison
Modified: 2017-07-19 16:31 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Morrison 2010-01-05 13:39:28 CET
If I select "use SSL" in an NNTP account then any articles posted produce an error indicating that posting was not successful. Looking at the network log shows that the last command seen was outgoing data:

[11:15:17] * message: creating NNTP connection to news.ukfsn.org:563 ...
[11:15:17] NNTP< 200 usenet.ukfsn.org InterNetNews NNRP server INN 2.4.4 (20060818 snapshot) ready (posting ok). 
[11:15:17] NNTP< Ok
[11:15:17] NNTP> POST 
[11:15:17] NNTP< 340 Ok, recommended ID <hhv705$em$1@localhost.localdomain> 
[11:15:17] NNTP> [data - 876 bytes]

a further data entry is seen:

[11:15:40] NNTP< [data - 444 bytes]

but it's difficult to be sure if this is associated with the same POST attempt.

On some occasions the posts in question do appear in the group, but others do not.

Posting without SSL works as expected.

Tried with Win32 version, 3.7.3cvs2 and also on Linux with 3.7.3cvs50.
Comment 1 Brian Morrison 2010-01-05 13:41:31 CET
Also noticed that each failed posting has this sort of exchange some time after it in the log, this is not present when posts are successful:

[11:16:17] NNTP> GROUP uk.radio.amateur 
[11:16:17] NNTP< 441 435 Duplicate 
[11:16:17] NNTP> MODE READER 
[11:16:17] NNTP< 211 6698 71528 78231 uk.radio.amateur 
[11:16:17] ** warning: couldn't select group: uk.radio.amateur
[11:16:17] ** warning: couldn't set group: uk.radio.amateur
Comment 2 Andrej Kacian 2017-03-19 10:14:09 CET
Brian, is this still an issue on newer Windows releases?
Comment 3 Brian Morrison 2017-03-19 22:31:38 CET
No, it certainly isn't with the current version (3.14.1) and hasn't been for some time.

I can't say exactly what fixed it, and after nearly 7 years I wouldn't know where to look. So many commits!