Bug 1963 - Preferences Templates Information Window Focus loss
Summary: Preferences Templates Information Window Focus loss
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.7.1
Hardware: PC Windows XP
: P3 minor
Assignee: users
URL:
: 2077 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-24 16:43 UTC by BrianA
Modified: 2012-11-22 15:47 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BrianA 2009-07-24 16:43:18 UTC
When I attempt to use Preferences>Templates>Information Window the focus stays on the template and I'm unable to move the focus to the information window to see the codes to use for set-up of the template.  I have to cancel the template window to get the information window to close.  

Using Collins svn1154 of CLAWS MAIL on WinXP Media Center 2005 with SP3 applied and an NVidia FX5200 with dual monitors activated.  

Thanks for any help.
Comment 1 David 2011-08-03 09:14:28 UTC
Same problem in 3.7. Fairly important since I can't find this info elsewhere.
Comment 2 users 2011-08-06 09:12:34 UTC
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.colino.net/claws-mail/

2011-08-06 [paul]	3.7.9cvs41

	* src/gtk/description_window.c
		fix bug 1963, 'Preferences Templates Information Window Focus loss'
Comment 3 users 2012-11-16 17:12:06 UTC
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.claws-mail.org/tracker/

2012-11-16 [colin]	3.9.0cvs10

	* src/foldersel.c
	* src/prefs_actions.c
	* src/prefs_filtering_action.c
	* src/prefs_matcher.c
	* src/quote_fmt.c
	* src/gtk/description_window.c
	* src/gtk/description_window.h
	* src/gtk/inputdialog.c
	* src/gtk/manage_window.c
	* src/gtk/quicksearch.c
		Try to better fix focus problems. Should address:
		Bug #2774
		Bug #2624
		Bug #1963
		Please check using your favorite WM that the following works:
		Information button (Quicksearch, Templates, 'Test' filtering 
		condition)
		Folder selection (Move/Copy contextual menu,
		various preferences, including 'New folder').
		Tested with XFCE, Gnome Shell and Windows.
		
Comment 4 Abhay S. Kushwaha 2012-11-22 15:45:48 UTC
This has indeed been fixed and works as desired on my Windows box in 3.9.0cvs12 (the latest build available for Windows).
Comment 5 Abhay S. Kushwaha 2012-11-22 15:47:25 UTC
*** Bug 2077 has been marked as a duplicate of this bug. ***