Bug 1959 - Selection selects too many under expanded view
Summary: Selection selects too many under expanded view
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Message List (show other bugs)
Version: 3.7.2
Hardware: PC Linux
: P3 minor
Assignee: users
URL:
: 2490 2967 3277 3513 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-21 20:59 CEST by Henning Mersch
Modified: 2015-10-20 23:34 CEST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henning Mersch 2009-07-21 20:59:35 CEST
Selecting multiple mails (e.g. for drag/dopping them to another folder), 
the Summary View aka Message list is used. 
Claws behaves a bit strange, if a combination of mouse and keyboard is 
used for navigation. Claws ends up in selecting mails, which arent expected to be selected. 

How to reproduce: 
Lets assume one selects a mail (lets name it A) in "Summary view" by mouse and afterwards uses arrow keys to move around to another mail (name B).
If shift-Mouse on a third mail (name C) is used, claws selects mails from
A to C.

I would expect mails from B to C to be selected, because B
is marked and A isnt marked in any way. 

I asked for comments on this at the users mailinglist:
Subject: (un)wanted multi-selection behaviour ...
Date: Sun, 19 Jul 2009 14:07:45 +0200

I use Ubuntu ppa packages on x86.
This is not new in 3.7.2 - I think it exists since ages, but I 
havent investigated this "strange" behaviour until now. 

Thanks.
Comment 1 Paul 2013-08-06 05:43:59 CEST
*** Bug 2967 has been marked as a duplicate of this bug. ***
Comment 2 Bernd Eckenfels 2014-02-06 22:37:43 CET
It is also a problem when you click one mail (Windows 7 in my case), then press shift and cursor down 2 times (selecting in total 3 mails). It is normally expected that if you release the shift key and click another mail, then the other mail should be selected and the original 3 selected mails should be deselected. What actually happs is, that the older 3 are still colored but not really selected. One has to ctrl+click them all 3 to get rid of the marker.

Might be related to Bug#2490
Comment 3 Ricardo Mones 2014-09-25 13:09:51 CEST
*** Bug 3277 has been marked as a duplicate of this bug. ***
Comment 4 Andrej Kacian 2015-10-20 23:34:06 CEST
Fixed in git now.
Comment 5 Andrej Kacian 2015-10-20 23:34:20 CEST
*** Bug 3513 has been marked as a duplicate of this bug. ***
Comment 6 Andrej Kacian 2015-10-20 23:34:43 CEST
*** Bug 2490 has been marked as a duplicate of this bug. ***