Bug 1743 - claws 3.6.0 segfaults on opening html email or RSS feed item w/ Gtkhtml2 Viewer plugin
Summary: claws 3.6.0 segfaults on opening html email or RSS feed item w/ Gtkhtml2 View...
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Gtkhtml2 Viewer (show other bugs)
Version: 3.6.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2008-10-05 10:29 UTC by Gabor Nyitrai
Modified: 2008-10-05 12:12 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Nyitrai 2008-10-05 10:29:56 UTC
Overview Description:
This bug wasn't present in 3.5.0.
After updating to 3.6.0, it throws Segmentation Fault error on opening HTML mail or RSS item with Gtkhtml2 Viewer plugin. Dillo Viewer displays them but without images.

Steps to Reproduce:
No special steps, just load the Gtkhtml2 Viewer plugin and display any RSS feed item or html email. See an example mail at the bottom.

Actual Results:
Segmentation Fault

Build Date & Platform:
Ubuntu Linux 8.04. I updated to ClawsMail 3.6.0, plugins, etc. from repository: deb http://ppa.launchpad.net/claws-mail/ubuntu hardy main

$ claws-mail --version-full
Claws Mail version 3.6.0
runtime GTK+ 2.12.9 / GLib 2.16.4
buildtime GTK+ 2.12.9 / GLib 2.16.4
Compiled-in features:
 compface
 aspell
 ipv6
 iconv
 jpilot
 ldap
 libetpan 0.56
 libsm
 NetworkManager
 openssl
Comment 1 Gabor Nyitrai 2008-10-05 10:33:44 UTC
Example mail that crashes gtkhtmlviewer:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!-- saved from url=(0014)about:internet -->
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>SzuperPiac.hu h&iacute;rlev&eacute;l</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />
<style type="text/css">
<!--
.style3 {font-family: Tahoma}
-->
</style>
</head>
<body bgcolor="#ffffff">
<p class="style3"><a href="http://www.szuperpiac.hu" target="_blank"></a>Tisztelt Hirdet_!</p>
<p class="style3">Emelje ki hirdet_s_t 
  a Szuperpiac f_oldal_ra, 
  valamint a rovata 
  els_ oldal_ra egyszer_en! <br />
  Mind_ssze 1500 Ft+_FA-_rt 
2 h_tre!</p>
<p class="style3">K_ldj_n SMS-t a 0690 648-311 sz_mra b_rmely h_l_zatb_l <strong>SUP azonos_t_</strong> sz_veggel. (SMS minta: SUP 12121)<br />
  <em>A hirdet_s_nek azonos_t_j_t a felad_sakor megk_ld_tt visszaigazol_ e-mailb_l, vagy a hirdet_s r_szletes oldal_n - a jobb fels_ sarokb_l tudhatja meg.</em><br />
  <br />
  Az SMS kiemelt hirdet&eacute;sek m&aacute;r a Port80.hu n&eacute;pszer&#369; kezd&#337;lapon is megjelennek! <a href="http://www.port80.hu" target="_blank">www.port80.hu</a><br />
<a href="http://www.port80.hu/" target="_blank" mce_href="http://www.port80.hu"><img height="40" alt=" Port80.hu" src="http://www.szuperpiac.hu/browser/partnereink/port80hu120.jpg" width="120" border="0" mce_src="../../browser/partnereink/port80hu120.jpg" /></a></p>
<p class="style3">Ha elfelejtette a bel_p_si jelszav_t - itt lek_rheti: <a href="http://www.szuperpiac.hu/jelszo" target="_blank">www.szuperpiac.hu/jelszo</a></p>
<p class="style3">_dv_zlettel,</p>
<p class="style3">A <a href="http://www.szuperpiac.hu" target="_blank"><img src="http://www.szuperpiac.hu/szplogo.jpg" width="160" height="40" border="0" /></a> csapat</p>
</body>
</html>
Comment 2 Paul 2008-10-05 10:50:38 UTC
FYI, it doesn't happen on 'any RSS feed item or html email'. I can't reproduce it. What is the subscription url for a feed with which this can be reproduced?
Comment 3 Gabor Nyitrai 2008-10-05 11:03:20 UTC
Strange, I get it with everything.
Two such feed links:
http://www.linux.com/feature/?theme=rss
http://feeds.feedburner.com/linuxhaxor/zvzl

(In reply to comment #2)
> FYI, it doesn't happen on 'any RSS feed item or html email'. I can't reproduce
> it. What is the subscription url for a feed with which this can be reproduced?
> 

Comment 4 Paul 2008-10-05 11:15:48 UTC
Both work fine for me. Are you using the latest version(s) of the plugin(s)?

gtkthml2_viewer 0.20
rssyl 0.21
Comment 5 Colin Leroy 2008-10-05 11:17:21 UTC
Can you install the claws-mail-dbg and claws-mail-extra-plugins-dbg packages, and get a crash backtrace?

http://www.claws-mail.org/faq/index.php/Debugging_Claws
Comment 6 Colin Leroy 2008-10-05 11:27:37 UTC
Hello,

Don't bother debugging; I just realised it's my fault. I've built the Ubuntu Claws Mail packages, then extra-plugins packages, then I fixed Claws Mail packages to re-add spellchecking - which changes some structures - and forgot to rebuild Extra Plugins. 

Fixed packages should be available in a few hours. Please update the bug status once you'll have Claws plugins upgradable!
Comment 7 Gabor Nyitrai 2008-10-05 11:36:23 UTC
Thank you!
I'll check the updates and see how it works.

(In reply to comment #6)
> Hello,
> 
Comment 8 Colin Leroy 2008-10-05 11:58:51 UTC
Updates should be available now.
Comment 9 Gabor Nyitrai 2008-10-05 12:12:51 UTC
It all works well now, thanks for the quick response!