Bug 1737 - Claws-Mail 3.6.0-1 crashes upon opening.
Summary: Claws-Mail 3.6.0-1 crashes upon opening.
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Maemo)
Classification: Unclassified
Component: General (show other bugs)
Version: 3.6.0
Hardware: Nokia n800 other
: P3 normal
Assignee: users
URL:
: 1738 1741 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-03 20:19 UTC by Robert Lotti
Modified: 2008-10-05 01:43 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Lotti 2008-10-03 20:19:57 UTC
I just installed the update to version 3.6.0-1 and now, when I select Claws-Mail, it opens for about 1 second and then spontaneously closes. The OS is Diablo
Comment 1 Colin Leroy 2008-10-03 20:50:13 UTC
Thanks for reporting. This seems to be a segfault related to the new menu code.

Workaround until I find and fix the problem: uninstall Claws and plugins; remove extras-devel and use extras instead; reinstall claws (3.5.0).
Comment 2 Myles Green 2008-10-03 22:26:20 UTC
Hmmm, just installed 3.6.0 on Linux Mint (Elyssa) which is based upon Ubuntu Hardy and everything seems fine here - no crashes yet at any rate. Maybe you've already fixed the 'problem'? I so, laissez les bontemps roulez!
Myles
Comment 3 Myles Green 2008-10-04 00:36:04 UTC
Sorry, I just realised this was a Mameo bug... my apologies for the noise.
Comment 4 Colin Leroy 2008-10-04 09:33:20 UTC
*** Bug 1738 has been marked as a duplicate of this bug. ***
Comment 5 users 2008-10-04 10:27:02 UTC
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.colino.net/claws-mail/

2008-10-04 [colin]	3.6.0cvs4

	* src/addressbook.c
	* src/compose.c
	* src/mainwindow.c
	* src/messageview.c
	* src/summaryview.c
		Maemo: Fix bug 1737, Crashes upon opening
Comment 6 Colin Leroy 2008-10-04 12:53:59 UTC
I have just uploaded 3.6.0-2 to extras-devel. Can you check?
Comment 7 ichneumon 2008-10-04 13:42:15 UTC
3.6.0-2 is working fine for me - thanks for the quick fix.
Comment 8 Colin Leroy 2008-10-04 13:56:13 UTC
Thanks! Packages promoted to extras as well.
Comment 9 Colin Leroy 2008-10-04 16:52:14 UTC
*** Bug 1741 has been marked as a duplicate of this bug. ***
Comment 10 Robert Lotti 2008-10-05 01:43:14 UTC
Thank you, I just downloaded it and installed it and it appears to work fine.