Bug 1128 - Weird stuff with icons
Summary: Weird stuff with icons
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Folder List (show other bugs)
Version: 2.7.2
Hardware: PC Linux
: P3 trivial
Assignee: users
URL: https://bugzilla.redhat.com/bugzilla/...
Depends on:
Blocks:
 
Reported: 2007-02-28 11:39 UTC by Konrad Kosmowski
Modified: 2007-03-01 13:16 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konrad Kosmowski 2007-02-28 11:39:51 UTC
As described in Fedora's Bugzilla:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=230020

Description of problem: When you launch Claws Mail (for other than first time)
it is missing icons in folder pane.

Version-Release number of selected component (if applicable): claws-mail-2.7.2-1.fc6

How reproducible: (In my system) Always

Steps to Reproduce:
1. Launch Claws Mail
2. Close it
3. Launch it again and observe folder pane - icons not show up.
  
Actual results: Folder icons do not show up
http://home.kosmosik.net/always/sc_actual.jpg

Expected results: Folder icons to show up
http://home.kosmosik.net/always/sc_expected.jpg

Additional info: Tested on only one system so maybe it is only my config. But
still it is perfectly healthly install and it should work.
Comment 1 Colin Leroy 2007-02-28 11:46:03 UTC
Can you include --debug output ?
Comment 2 Konrad Kosmowski 2007-02-28 11:59:44 UTC
claws.c:98:Starting Claws Mail version 02070200
prefs_gtk.c:1003:new file '/srv/home/konrad/.claws-mail/clawsrc'
prefs_gtk.c:962:new section 'Plugins_GTK2'
prefs_gtk.c:962:new section 'Common'
prefs_gtk.c:962:new section 'Plugins_Common'
prefs_gtk.c:962:new section 'NotificationPlugin'
prefs_gtk.c:962:new section 'AttachWarner'
prefs_gtk.c:962:new section 'gtkhtml2'
prefs_gtk.c:962:new section 'VCalendar'
prefs_gtk.c:962:new section 'rssyl'
prefs_gtk.c:1003:new file '/srv/home/konrad/.claws-mail/folderitemrc'
prefs_gtk.c:962:new section '#mh/mail/inbox'
prefs_gtk.c:962:new section '#news/usenet/alt.pl.comp.os.linux.fedora'
[groups and mailboxes go here nothing unusual]
prefs_gtk.c:1003:new file '/srv/home/konrad/.claws-mail/accountrc'
prefs_gtk.c:962:new section 'Account: 4'
[accounts...]
prefs.c:283:Found [Plugins_Common]
current dir: /srv/home/konrad/.claws-mail
current dir: /srv/home/konrad
folder.c:114:registering folder class mh
folder.c:114:registering folder class imap
folder.c:114:registering folder class news
prefs_gtk.c:82:Reading configuration...
prefs_themes.c:365:Creating preferences for themes...
stock_pixmap.c:462:dir /usr/share/claws-mail/themes not found, skipping theme scanprefs_actions.c:360:Reading actions configurations...
prefs_display_header.c:402:Reading configuration for displaying headers...
addressbook.c:3694:Reading address index...
addressbook.c:3726:done.
mainwindow.c:1124:Creating main window...
toolbar.c:596:read Toolbar Configuration from toolbar_main.xml
folderview.c:594:Creating folder view...
folderview.c:456:creating tree...
hooks.c:70:registed new hook for 'folder_update' as id 1
hooks.c:70:registed new hook for 'folder_item_update' as id 1
summaryview.c:567:Creating summary view...
hooks.c:70:registed new hook for 'msginfo_update' as id 1
hooks.c:70:registed new hook for 'folder_item_update' as id 2
messageview.c:342:Creating message view...
headerview.c:82:Creating header view...
noticeview.c:77:Creating notice view...
mimeview.c:208:Creating MIME view...
noticeview.c:77:Creating notice view...
textview.c:270:Creating text view...
hooks.c:70:registed new hook for 'msginfo_update' as id 2
logwindow.c:82:Creating log window...
hooks.c:70:registed new hook for 'log_append_text' as id 1
mainwindow.c:1351:done.
mainwindow.c:2691:Setting widgets... mainwindow.c:1865:Changing window separation type from 1 to 1
mainwindow.c:2948:done.
mainwindow.c:1978:called after messageview has been deallocated!
mainwindow.c:1978:called after messageview has been deallocated!
hooks.c:70:registed new hook for 'sslcert_ask' as id 1
hooks.c:70:registed new hook for 'progressindicator_hooklist' as id 1
account.c:188:Reading all config for each account...
account.c:203:Found label: Account: 4
account.c:203:Found label: Account: 6
account.c:203:Found label: Account: 7
account.c:203:Found label: Account: 5
codeconv.c:1458:current locale: pl_PL.UTF-8
prefs_gtk.c:82:Reading configuration...
prefs_customheader.c:327:Reading custom header configuration...
prefs_gtk.c:82:Reading configuration...
prefs_customheader.c:327:Reading custom header configuration...
prefs_gtk.c:82:Reading configuration...
prefs_customheader.c:327:Reading custom header configuration...
prefs_gtk.c:82:Reading configuration...
prefs_customheader.c:327:Reading custom header configuration...
folderview.c:385:setting titles...
folderview.c:718:Setting folder info...
summaryview.c:990:empty folder ((nil) NULL (nil) 0)
summaryview.c:1010:TIMING summary_show : 0s000ms
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:1070:no '#mh/mail/queue' section in '/srv/home/konrad/.claws-mail/folderitemrc' cache
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:1070:no '#mh/mail/trash' section in '/srv/home/konrad/.claws-mail/folderitemrc' cache
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:1070:no '#mh/mail/Archive' section in '/srv/home/konrad/.claws-mail/folderitemrc' cache
prefs_gtk.c:82:Reading configuration...
[prefs... repeats]
prefs_gtk.c:1070:no '#mh/mail/Mailing' section in '/srv/home/konrad/.claws-mail/folderitemrc' cache
prefs_gtk.c:82:Reading configuration...
prefs_gtk.c:1070:no '#mh/mail/Foo' section in '/srv/home/konrad/.claws-mail/folderitemrc' cache
folderview.c:718:Setting folder info...
prefs_gtk.c:82:Reading configuration...
[prefs... repeats]
folderview.c:718:Setting folder info...
folder.c:3962:Folder mail wants sync: 0
folder.c:3962:Folder News wants sync: 0
folder.c:3962:Folder mail wants sync: 0
folder.c:3962:Folder News wants sync: 0
folderview.c:2089:TIMING folderview_selected : 0s000ms
folderview.c:718:Setting folder info...
inc.c:1408:added timer = 68
prefs.c:283:Found [Plugins_GTK2]
plugin.c:307:trying to load `/usr/lib/claws-mail/plugins/attachwarner.so'
hooks.c:70:registed new hook for 'compose_check_before_send' as id 1
prefs_gtk.c:82:Reading configuration...
attachwarner.c:288:Attachment warner plugin loaded
plugin.c:365:Plugin Attach warner (from file /usr/lib/claws-mail/plugins/attachwarner.so) loaded
plugin.c:307:trying to load `/usr/lib/claws-mail/plugins/gtkhtml2_viewer.so'
prefs_gtk.c:1041:destroying cache
main.c:970:TIMING main startup: 2s348ms
inc.c:1420:removed timer = 68
[rest goes POP and NNTP sessions]
Comment 3 Paul 2007-02-28 12:28:07 UTC
I can't reproduce this. Does this happen on all custom themes, or just your own?
Comment 4 Konrad Kosmowski 2007-02-28 12:30:49 UTC
I haven't checked other themes. But it happens even if I delete my nondefault. Maybe it is something with my config.
Comment 5 Paul 2007-03-01 07:35:20 UTC
Can you check with another theme, e.g. Clawsola, http://www.claws-mail.org/themes/claws-mail-theme_clawsola.tar.gz

I think this could be caused by your theme's xpm files being broken.
For example, the 2nd line of the file dir_close.xpm should say

static char * dir_close_xpm[] = {

but your theme's dir_close_xpm says

static char * closed_xpm[] = {

The 2nd line of an xpm file should match the file name.
Comment 6 Konrad Kosmowski 2007-03-01 13:16:10 UTC
Paul, I think it was some syntetic constriant about this XPM header. The theme worked when selected manually. It failed upon start of program. Anyway it looks like this is resolved in 2.8 and now I got this version and problem disapeared. :)