Bug 2624

Summary: dialog "Action Configuration" cannot be closed
Product: Claws Mail Reporter: K. Bronsen <housetier>
Component: FilteringAssignee: users
Status: RESOLVED FIXED    
Severity: normal CC: drey.tee, fox, sergeyzsg
Priority: P3    
Version: 3.8.0   
Hardware: PC   
OS: Linux   

Description K. Bronsen 2012-03-07 09:52:42 CET
When I click "Define" to define a new action for a filter, a dialog named "Action configuration" opens. This dialog window cannot be closed via normal means.

Attempted methods of closing this dialog window:
- clicking button OK
- clicking button Cancel
- clicking the 'X' from the window manager's window decoration
- pressing ESC
- typing window manager's keyboard shortcut for closing windows


However,from the still opened dialog "Filtering configuration" I can open new dialogs for "Condition configuration", and these are closable.


System Information:

% lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 11.10
Release:        11.10
Codename:       oneiric

% apt-cache policy claws-mail
claws-mail:
  Installed: 3.8-0-1ubuntu1ppa1
  Candidate: 3.8-0-1ubuntu1ppa1
  Version table:
 *** 3.8-0-1ubuntu1ppa1 0
        500 http://ppa.launchpad.net/claws-mail/ppa/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
     3.7.9-1ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages


This bug is reproducable.
Comment 1 K. Bronsen 2012-03-07 12:23:16 CET
additional System Information:

I use xfce as desktop environment.
Comment 2 Christian Hesse 2012-03-13 12:07:49 CET
I think the problem is somewhere else:

* open any configuration dialog that has an "Information" button
* open the information dialog
* close the information dialog

-> You can not interact with the configuration dialog and chances are very high that CM crashes later.

Can anybody confirm?
Comment 3 fx 2012-05-12 13:00:53 CEST
Similar/same problem hear.

Clicking "Create filter menu" from context menu.
Clicking "Define" next to the action field, brings up "Action Configuration".
In "Action configuration" nothing is clickable.

The only way to get out of this, is to focus "Filtering Configuration", select another rule, cancel the Filtering Configuration dialogue, and then cancel the other dialogues.

This is on ubuntu 12.04, with XFCE, amb64.
Comment 4 users 2012-05-16 08:08:34 CEST
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.claws-mail.org/tracker/

2012-05-16 [paul]	3.8.0cvs42

	* src/gtk/description_window.c
		fix bug 2624, 'dialog "Action Configuration" cannot be closed'
Comment 5 Paul 2012-05-22 07:14:07 CEST
*** Bug 2666 has been marked as a duplicate of this bug. ***
Comment 6 users 2012-11-16 17:11:55 CET
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.claws-mail.org/tracker/

2012-11-16 [colin]	3.9.0cvs10

	* src/foldersel.c
	* src/prefs_actions.c
	* src/prefs_filtering_action.c
	* src/prefs_matcher.c
	* src/quote_fmt.c
	* src/gtk/description_window.c
	* src/gtk/description_window.h
	* src/gtk/inputdialog.c
	* src/gtk/manage_window.c
	* src/gtk/quicksearch.c
		Try to better fix focus problems. Should address:
		Bug #2774
		Bug #2624
		Bug #1963
		Please check using your favorite WM that the following works:
		Information button (Quicksearch, Templates, 'Test' filtering 
		condition)
		Folder selection (Move/Copy contextual menu,
		various preferences, including 'New folder').
		Tested with XFCE, Gnome Shell and Windows.
		
Comment 7 Sergey Chuprakov 2012-11-29 08:38:51 CET
I built 3.9.0cvs29 ubintu 12.10, and I can't add a filtering action via "Define..." button still.
Buttons Add, Cancel, and any of field don't available. They are available when I close "filtering configuration" window.
Comment 8 Paul 2012-11-29 08:44:35 CET
Sergey - you're using Unity??
Comment 9 Sergey Chuprakov 2012-11-29 08:45:40 CET
Yes, I am.
Comment 10 Abhay S. Kushwaha 2012-11-29 08:49:05 CET
FWIW, this is not happening for me and the dialog box behaves as it should.
Comment 11 Paul 2012-11-29 08:51:27 CET
Sergey, bugs #2694 and #2758 are also Unity issues
Comment 12 Sergey Chuprakov 2012-11-29 08:57:09 CET
> Sergey, bugs #2694 and #2758 are also Unity issues
I can reproduce only #2758