Bug 2162 - configure check for libetpan fails with libetpan 1.0
: configure check for libetpan fails with libetpan 1.0
Status: RESOLVED FIXED
Product: Claws Mail
Classification: Unclassified
Component: Other
: 3.7.6
: PC Linux
: P3 normal
Assigned To: users
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-09 18:51 CEST by Didier Barvaux
Modified: 2010-04-12 21:35 CEST (History)
1 user (show)

See Also:


Attachments
Fix check for libetpan version in configure.ac (1.94 KB, patch)
2010-04-09 18:51 CEST, Didier Barvaux
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Didier Barvaux 2010-04-09 18:51:20 CEST
Created attachment 830 [details]
Fix check for libetpan version in configure.ac

libetpan 1.0 has just been released. With libetpan 1.0, Claws Mail 3.7.5 and 3.7.5cvs43 both fail during ./configure with the following message:

  checking whether to use libetpan... yes
  checking for libetpan-config... /usr/bin/libetpan-config
  checking libetpan/libetpan.h usability... yes
  checking libetpan/libetpan.h presence... yes
  checking for libetpan/libetpan.h... yes
  checking whether libetpan-config hints compiles and links fine... yes
  *** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/
  *** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.
  configure: error: libetpan 0.57 not found

The problem is that "libetpan-config --version" now returns 1.0 and not 0.XX anymore. The check in configure removes the dot in the version string and compares the resulting number with 057. 10 is lesser than 57 so it fails. The bug probably affects versions < 3.7.5 too.

The attached patch fixes the faulty libetpan check in configure.ac. The patch also adds calls to AC_MSG_CHECKING/AC_MSG_RESULT macros to make the check more verbose.

The patch was successfully tested on a Gentoo x86 system with libetpan-0.56, libetpan-0.57, libetpan-0.58 and libetpan-1.0.
Comment 1 Paul 2010-04-11 11:18:24 CEST
*** Bug 2163 has been marked as a duplicate of this bug. ***
Comment 2 users 2010-04-12 16:20:34 CEST
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.colino.net/claws-mail/

2010-04-12 [colin]	3.7.5cvs45

	* configure.ac
		Fix bug 2162, 'configure check for libetpan 
		fails with libetpan 1.0'
Comment 3 Didier Barvaux 2010-04-12 21:05:16 CEST
Successfully tested with Claws Mail 3.7.5cvs45 and libetpan 1.0. I change the bug status to RESOLVED/FIXED.

Your change in configure.ac is a quick hack. It fixes the problem now, but it will not work anymore if Claws Mail requires libetpan > 1.x for example.
Comment 4 Paul 2010-04-12 21:18:26 CEST
OTOH, the attached patch just does not work.
Comment 5 Colin Leroy 2010-04-12 21:25:21 CEST
As I hadn't noticed the presence of an attachment in this report, I wrote my own version of the thing :)
Comment 6 Didier Barvaux 2010-04-12 21:34:07 CEST
> OTOH, the attached patch just does not work.

Uh, are you sure ? I tested it with libetpan 0.56/0.57/0.58/1.0. What was the
problem ?
Comment 7 Didier Barvaux 2010-04-12 21:35:22 CEST
> As I hadn't noticed the presence of an attachment in this report,
> I wrote my own version of the thing :)

No problem :)